Este post foi originalmente publicado em http://officevbavsto.blogspot.com/2011/02/melhores-praticas-para-uma-procv-parte.html.

Continuando meu artigo sobre melhores práticas para a função PROCV, hoje, eu escrevo sobre as melhores práticas.

Usar intervalo nomeado como matriz_tabela

Relembrando, matriz_tabela é o segundo argumento de uma PROCV onde eu delimito o intervalo em que será feita a busca do meu valor_procurado.

Sua estrutura é: =PROCV(valor_procurado; matriz_tabela; núm_índice; [procurar_intervalo]) .

Intervalo nomeado

Ao invés de você apontar para um intervalo de células passando o endereço delas ("A1:C5", por exemplo), você cria um nome para esse intervalo e aponta para esse nome.

Veja o exemplo abaixo:

A fórmula que está sendo utilizada na Imagem 1 é =PROCV(I6;A1:G28;2;0).

Suponha que esta fórmula estivesse em outra planilha e uma outra pessoa fosse analisá-la. Qual seria a primeira coisa que essa pessoa perguntaria? Acredito que seja, o que eu tenho no intervalo A1:G28?

Veja o exemplo da imagem 2 abaixo:

A fórmula que está sendo utilizada na Imagem 2 é =PROCV(I6;populacao_por_municipio_SP;2;0).

Você também pode fazer o seguinte: pressione F5, selecione o nome do intervalo nomeado na lista do "Ir para:" e clique em OK. Você será levado direto para o intervalo do intervalo nomeado.

Como adicionar um intervalo nomeado?

Excel 2007 e 2010: clique na Aba Fórmulas -> Definir Nomes -> digite no nome no campo Nome -> clique em OK.

Excel 2003 e versões anteriores: Inserir -> Nome -> Definir -> digite o nome no campo Nomes na pasta de trabalho -> clique em OK.

Tratar erros

Não existe nada mais desagradável do que você abrir uma planilha e ver aquele monte de erros: #N/D.

O erro que você deve se preocupar é o #N/D, pois ele é comum de acontecer, pois não significa que a fórmula esteja errada, mas o valor_procurado não existe na matriz_tabela. Os demais devem ser visto no momento em que aparecerem.

Use a fórmula SE concatenada com o É.NÃO.DISP:

=SE(É.NÃO.DISP(PROCV(I6;populacao_por_municipio_SP;2;0));"";PROCV(I6;populacao_por_municipio_SP;2;0))

Esta fórmula significa que se retornar o erro #N/D, mostre branco ("", aqui você pode colocar o que quiser. Se texto, entre em aspas), caso contrário, mostre o valor retornado pela PROCV.

Use a fórmula SE concatenada com o ÉERROS ou SEERRO:

Não é recomendado você utilizar "SE(ÉERROS(valor);[valor_se_verdadeiro];[valor_se_falso])", pois não é garantido que sempre será o erro #N/D. Pode ser que sua fórmula tenha um outro erro e você não detectará desta forma. Agora, se você tem certeza de que a sua PROCV está correta, então pode utilizar.

Na versão 2007 e 2010, você pode utilizar o SEERRO(valor;valor_se_erro).
Sua fórmula ficará mais legível.

=SEERRO(PROCV(I6;populacao_por_municipio_SP;2;0);"Valor não encontrado!")

Créditos

Photo by Oleg Magni from Pexels